….and we’re back.

Posted on November 13th, 2013 No comments. The post is really that bad, huh?

Greatest of apologies, dear TCL reader, for our unexpected outage over the past few days. I’d accidentally allowed the domain name to lapse, which shouldn’t have been a big issue except … it was! After three “escalations”, four assurances that things were restored (apparently no one checked to see if this was actually true or not), and what I honestly estimate as roughly 8 hours on the phone with multitudes of customer service reps, I finally managed to break through to someone beyond front-line support.

Although I was shitting bricks about the situation, the end result is infinitely better than the whore bitches at 1&1 Internet, a domain registrar I was with previously who quite literally sold another one of my established domains without so much as a peep (and I spent an entire month trying to contact those fuckers, that time well in advance of the expiration).

I’ve worked hard over the past 5 years to build up TCL to where it is today, and the thought of someone stealing it from me was unbearable. Plus there’s the matter of email addresses which, whoever the other domain was sold to, can now abuse and use to hack into any associated accounts I’d neglected to change. Nightmare.

I left 1&1 a long time ago, and I highly suggest that if you have any accounts with them that you move them ASAP. Or you can discover for yourself how little recourse customers have when shit goes south — much like being stuck with Rob Ford for four years.

In any event, thanks to my host for finally getting their shit together, and thank you for your patience!

What's on your mind?